腾博会娱乐

 找回密码
 成员注册

腾博会娱乐官方网

只需一步,快速开始

腾博会娱乐cames
腾博会娱乐官网 qq透明度软件 相机
查看: 5368|回复: 1

[网络] 企业网络中DHCP服务器的典型配置

[复制链接]
发表于 2011-4-27 21:11:15 | 显示全部楼层 |阅读模式
DHCP(动态主机控制协议)服务器是企业网络中常用的服务器,它简化了企业内部IP地址的分配与管理,可以极大地提高网络管理的效率,减少日常维护和管理IP地址的工作量。下面将以典型企业网络环境为例,说明DHCP服务器及网络环境的规划与配置。
1.典型企业网络概述
1.1 网络三层架构介绍
典型企业网络一般采用三层架构:核心层、汇聚层、接入层。核心层设备用于实现整个内部网络数据的转发,因此设备性能要求较高,一般使用多功能路由交换机;汇聚层设备用于实现部门内部的网络数据转发,一般使用三层网络交换机;接入层设备用于直接连接用户桌面设备,一般使用二层网络交换机。典型企业网络环境如下图1所示。

1 典型企业网络环境
1.2 VLANIP地址的规划
从数据的安全性考虑,同时为了尽可能减少网络中广播风暴的影响,企业网络一般划分为多个VLAN(虚拟局域网)。本例以上图1为例,将企业网络划分为5VLAN,更多VLAN的情况,配置方法类似,核心交换机的VLAN设置如下表1所示。
1  核心交换机的VLAN配置情况表
VLAN编号

端口范围

IP地址

VLAN10

1-8

192.168.1.1/24

VLAN20

9-16

192.168.2.1/24

VLAN30

17-22

192.168.3.1/24

VLAN90

23

10.0.0.2/30

VLAN100

24

192.168.100.1/24

其中1-8口连接VLAN10网段内的汇聚层的交换机,9-16口连接VLAN20网段内的汇聚层的交换机,17-22口连接VLAN30网段内的汇聚层的交换机,23口连接VLAN90网段内的汇聚层的交换机(此处用于上连路由器等出口设备),24口连接VLAN100网段内的汇聚层的交换机(此处用于连接DHCP服务器)。
2DHCP服务器的配置
2.1  基于Windows环境的DHCP服务器配置
配置DHCP服务器的IP地址为:192.168.100.5/24,默认网关为:192.16.100.1。然后安装和配置DHCP服务器,新建4个作用域,如下图2所示。

2  DHCP作用域范围
具体参数如下表2所示。
2  DHCP作用域参数详细参数
IP地址范围

默认网关(路由器)

DNS

192.168.100.100192.168.100.105

192.168.100.1

202.102.192.68

192.168.1.100192.168.1.200

192.168.1.1

202.102.192.68

192.168.2.100192.168.2.200

192.168.2.1

202.102.192.68

192.168.3.100192.168.3.200

192.168.3.1

202.102.192.68

注:DNS要根据实际情况设定,不同地区和不同服务供应商提供的DNS是不一同的,此处以陕西电信接入网络DNS服务器为例进行设置的。
2.2 基于Linux 环境的DHCP配置
配置DHCP服务器的IP地址为:192.168.100.5/24,默认网关为:192.168.100.1。然后修改/etc/dhcpd.conf文件,内容如下。
  ddns-update-style none;
  ignore client-updates;
  subnet 192.168.100.0 netmask 255.255.255.0 {
  option routers          192.168.100.1;
  option subnet-mask        255.255.255.0;
  option domain-name-servers    202.102.192.68;
  range dynamic-bootp 192.168.100.100 192.168.100.105;
  default-lease-time 21600;
  max-lease-time 43200;
  }
  subnet 192.168.1.0 netmask 255.255.255.0 {
  option routers          192.168.1.1;
  option subnet-mask        255.255.255.0;
  option domain-name-servers    202.102.192.68;
  range dynamic-bootp 192.168.1.100 192.168.1.200;
  default-lease-time 21600;
  max-lease-time 43200;
  }
  subnet 192.168.2.0 netmask 255.255.255.0 {
  option routers          192.168.2.1;
  option subnet-mask        255.255.255.0;
  option domain-name-servers    202.102.192.68;
  range dynamic-bootp 192.168.2.100 192.168.2.200;
  default-lease-time 21600;
  max-lease-time 43200;
  }
  subnet 192.168.3.0 netmask 255.255.255.0 {
  option routers          192.168.3.1;
  option subnet-mask        255.255.255.0;
  option domain-name-servers    202.102.192.68;
  range dynamic-bootp 192.168.3.100 192.168.3.105;
  default-lease-time 21600;
  max-lease-time 43200;
  }
然后重新启动DHCP服务,使用命令service dhcpd  restart
注:为了以后每次重启系统都能自动启用DHCP服务,可使用ntsysv命令窗口进行配置。
3.核心交换机的配置(本例以锐捷3500为例)
3.1 交换机的VLAN配置如下表3所示。
3  核心交换机的VLAN、端口及IP地址的配置
VLAN Name

Status

Ports

VLANIP地址

1    default

active

10   VLAN0020

active

Fa0/1 ,Fa0/2 ,Fa0/3 ,Fa0/4, Fa0/5 ,Fa0/6 ,Fa0/7 ,Fa0/8

192.168.1.1/24

20   VLAN0020

active

Fa0/9 ,Fa0/10,Fa0/11,Fa0/12, Fa0/13,Fa0/14,Fa0/15,Fa0/16

192.168.2.1/24

30   VLAN0030

active

Fa0/17,Fa0/18,Fa0/19,Fa0/20,Fa0/21,Fa0/22

192.168.3.1/24

90   VLAN0090

active

Fa0/23

10.0.0.2/30

100  VLAN0100

active

Fa0/24

192.168.100.1/24

2)交换机的配置操作如下(本例以锐捷3500为例):
3550#configure terminal
3550(config)#vlan 10
3550(config-vlan)#exit
3550(config)#vlan 20
3550(config-vlan)#exit
3550(config)#vlan 30
3550(config-vlan)#exit
3550(config)#vlan 100
3550(config-vlan)#exit
3550(config)#interface vlan 10
3550(config-if)#ip address 192.168.1.1 255.255.255.0
3550(config-if)#exit
3550(config)#interface vlan 20
3550(config-if)#ip address 192.168.2.1 255.255.255.0
3550(config-if)#exit
3550(config)#interface vlan 30
3550(config-if)#ip address 192.168.3.1 255.255.255.0
3550(config-if)#exit
3550(config)#interface vlan 90
3550(config-if)#ip address 10.0.0.2 255.255.255.252
3550(config-if)#exit
3550(config)#interface vlan 100
3550(config-if)#ip address 192.168.100.1 255.255.255.0
3550(config-if)#exit
3550(config)#interface range fastEthernet 0/1-8
3550(config-if-range)#switchport mode access
3550(config-if-range)#switchport access vlan 10
3550(config-if-range)#exit
3550(config)#interface range fastEthernet 0/9-16
3550(config-if-range)#switchport mode access
3550(config-if-range)#switchport access vlan 20
3550(config-if-range)#exit
3550(config)#interface range fastEthernet 0/17-22
3550(config-if-range)#switchport mode access
3550(config-if-range)#switchport access vlan 30
3550(config-if-range)#exit
3550(config)#interface fastEthernet 0/23
3550(config-if)#switchport mode access
3550(config-if)#switchport access vlan 90
3550(config-if-range)#exit
3550(config)#interface fastEthernet 0/24
3550(config-if)#switchport mode access
3550(config-if)#switchport access vlan 100
3550(config-if-range)#exit
3550(config)#ip routing
3550(config)#service dhcp
3550(config)#ip helper-address 192.168.100.5
3550(config)#end
3550#copy running-config startup-config
到此已经完成了典型企业网络环境下利用DHCP服务器分配IP地址的配置。连接在不同VLAN的客户端计算机将自动获得不同网段的IP地址。VLAN10网段的客户端计算机将获得192.168.1.100192.168.1.200之间的IP地址;VLAN20网段的客户端计算机将获得192.168.2.100192.168.2.200之间的IP地址;VLAN30网段的客户端计算机将获得192.168.3.100192.168.3.200之间的IP地址。更多VLAN的配置与此相似。
4.注意事项
1DHCP服务器网关的配置
DHCP服务器的网关一定要设置,并且为与之相连的交换机的VLANIP地址。否则,客户端将不能够获得IP地址。
2)交换机VLAN的配置
交换机上VLANIP地址一定要配置为客户端主机的网关地址,否则客户端也无法自动获得IP地址。
3)启用路由功能
作为核心交换机,一定要启用路由功能,在特权模式下运行ip routing命令即可。
4)不要创建超级作用域
创建超级作用域后,服务器将按照地址池中的IP地址顺序分配给客户端,客户端将不能获得正确的IP地址。
回复

使用道具 举报

您需要腾博会娱乐后才可以回帖 腾博会娱乐 | 成员注册

本版积分规则

|腾博会娱乐 ( )

GMT+8, 2019-9-3 18:52

Powered by X3.4

© 2001-2017

腾博会娱乐tb老虎机 腾博会娱乐tb老虎机 腾博会娱乐官方网